QUEUE

PCQ

AUDITORIAS

FACTURACION

INVENTARIO

13
July
2012

Poner logo de tu empresa en el msn de los clientes

Debido a que la gran mayoria de los clientes usan este sistema de mensajeria se me ocurrio poner la publicidad de mi empresa o cualquiera.

Este es un truquito simple para sacar la publi que sale debajo del messenger. La podes bloquear o poner la tuya ja ja.

Cada vez que se inicia sesion messenger solicita a rad.msn.com el banner , en realidad no pide un banner especifico si no tienen algo mas complejo que rota los banner segun lo pactado con el anunciante. Pero eso no viene al caso aunque se podria hacer tambien pero vamos a la base , despues esta en ustedes perfeccionarlo.

Lo principal es saber la ip de rad.msn.com , como en el firewall de mikrotik no se puede usar dominios solo direcciones ip hay que hacerlo por ip. Pero rad.msn.com cambia la ip constantemente tienen que descubrir que rango ip pertenece a cada lugar , pais, etc. Para argentina los rangos son

65.55.197.0 - 65.55.197.255
65.55.249.0 - 65.55.249.255

Si hay alguno mas por favor publicarlo a mi estos me estan funcionando.

Bueno ahora si. Vamos a redirigir todo lo que se pida ahi a nuestro proxy transparente en mikrotik

/ip firewall nat
add action=dst-nat chain=dstnat comment="Banner MSN" disabled=no dst-address=65.55.197.0/24 dst-port=80 protocol=tcp to-addresses=192.168.2.5 to-ports=3128
add action=dst-nat chain=dstnat comment="Banner MSN" disabled=no dst-address=65.55.249.0/24 dst-port=80 protocol=tcp to-addresses=192.168.2.5 to-ports=3128


Ahora todo lo que llege al proxy con ese dominio ( aca si ya podemos usar dominios ) lo dirigimos a nuestro banner.

/ip proxy access add action=deny comment="Banner MSN" disabled=no dst-host=rad.msn.com redirect-to=www.tudomino.com.ar/Bannerquequieras.gif

Categories: Scripts

Comments (0)

Leave a comment

You are commenting as guest.